Lesson 7: Creating Reports

Reports organize and summarize data for viewing online or for printing. A detail report displays all of the selected records. You can include summary data such as totals, counts, and percentages in a detail report. A summary report does not list the selected records but instead summarizes the data and presents totals, counts, percentages, or other summary data only. Access has several report generation tools that you can use to create both detail and summary reports quickly. This lesson teaches you how to create reports.

Use the Report Button

The Report button creates a simple report that lists the records in the selected table or query in a columnar format.

To use the Report button:
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1. Open the Navigation pane.

2. Click the table or query on which you want to base your report.

3. Activate the Create tab.

4. Click the Report button in the Reports group. Access creates your report and displays your report in Layout view. You can modify the report.
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 Tip: After you create a report, you can save it.

1. Click the Save button on the Quick Access toolbar. Access saves the report unless you are saving for the first time. If you are saving for the first time, the Save As dialog box appears.

2. Type the name you want to give your report.

3. Click OK. Access saves the report. You can now access the report by using the Navigation pane.

As with other objects, you can also save a report by right-clicking the reports tab and selecting Save. Saved reports appear in the Navigation pane.
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 Tip: Reports created by using the Report button are plain and simple. The Modify a Report section of this lesson teaches you how to customize a report to meet your needs.
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 Tip: Access reports created simply by using the Report button have several sections. They are detailed in the following table.

	Sections of a Report 

	Report Header
	Appears at the top of the first page and displays the report title.

	Page Header
	Appears at the top of every page and displays the headings (field labels) for each column.

	Page Footer
	Appears at the bottom of every page and displays the page number and total number of pages.

	Detail Section
	Appears between the page header and page footer and displays the records from the table or query.

	Report Footer
	This section is optional. Appears on the last page of the report and displays summary information such as grand totals.
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Use the Report Wizard

You can also use the Report Wizard to create a report. The Report Wizard provides you with more flexibility than you get by using the Report button. You can choose the tables and fields, group the data, sort the data, summarize the data, choose a layout and orientation, apply a style, and title your report. Follow the steps shown here to create a report by using the Report Wizard:

To create a report by using the Report Wizard:

Open the Report Wizard

[image: image7.png]



1. Activate the Create tab.

2. Click Report Wizard in the Reports group. The Report Wizard appears.

Select tables, queries and fields

When using the Report Wizard, you can use fields from multiple tables and/or queries if the tables/queries have a relationship.
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1. Click the down-arrow next to the Table/Queries field and then click the table from which you want to select fields.

2. Click a field and then click the single-right arrow to select a single field, click the double-right arrows to select all fields, click a field and then click the single-left arrow to deselect a single field, or click the double-left arrow to deselect all fields.

3. Repeat steps 1 and 2 for each table from which you want to select fields.

4. Click Next. The Report Wizard moves to the next page.

Group

When using the Report Wizard, you can group data. Grouping puts all of the values in a field into a group based on the field’s value. For example, if your data is grouped by the Department field and the records in the Department field have values such as Administration, Computer Science, and English. Access will group all of the data for the Administration department together, all of the data for the Computer Science department together, and all of the data for the English department together.
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1. Click to select the field by which you want to group your data. You may not see this page of the wizard if you are selecting data from a single table.

2. Click Next. The Report Wizard moves to the next page.
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3. Click a field you want to group by.

4. Click the right-arrow to select a field; click a field and then click the left arrow to deselect a field. Use the up- and down-arrows to change the order of the groupings. If you are only using one table, this may be your first opportunity to select a field to group by.

5. Repeat steps 3 and 4 for each field you want to group by.

6. Click Next. The Report Wizard moves to the next page.

Sort and summarize

By using the Report Wizard, you can create up to four levels of sort. Access sorts the first level, and then sorts the second level within that sort, and so on. If you have grouped your data, you can summarize it by displaying the sum, average, and minimum or maximum value for each numeric field. You can choose to have your report display just the summary data or each detail line and the summary data. There is also an option that allows you to display the percent the sum of each group is of the grand total. All of the fields in your report may not fit on a single page. You can have Access automatically adjust the size of the font so that every field fits.
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1. Click the down-arrow and then select the field you want to sort by.

2. Click the button to choose ascending or descending order. Clicking the button toggles between Ascending and Descending. You can sort up to four levels.

3. Click the Summary Options button. The Summary Options window appears.
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4. Click to select the summary data you want.

5. Click to select whether you want detail and summary data or if you want summary data only.

6. Click if you want to calculate the percent to the total for sums.

7. Click OK. The Summary Options window closes.

8. Click Next. The Report Wizard moves to the next page.

Layout and orientation

You can choose the layout and orientation of your report. The layout determines where each field appears on the page. Access provides three options to choose from: Stepped, Block, and Outline. When you choose an option, the left side of the window displays a graphic of the layout.

Orientation determines whether Access creates the report in portrait or landscape. Most paper, such as paper sized 8 1/2 by 11, is longer on one edge than it is on the other. If you print in Portrait, the shortest edge of the paper becomes the top of the page. Portrait is the default option. If you print Landscape, the longest edge of the paper becomes the top of the page.
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1. Click to select a layout.

2. Click to select a page orientation.

3. Choose the Adjust The Field Width So All Fields Fit On A Page option if you want all fields to fit on a single page.

4. Click Next. The Report Wizard moves to the next page.

Style

A style is a set of formats consisting of such things as background colors, fonts, font colors, and font sizes. Access supplies predesigned styles that format titles, labels, and more. When you choose a style, the left side of the window displays a preview.
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1. Click to select a style.

2. Click Next. The Report Wizard moves to the next page.

Create a title

On the final page of the Report Wizard, you can title your report. The title appears at the top of the report and on the Navigation pane.
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1. Type the title you want to give the report.

2. Click Finish. Access creates, saves, and opens your report in Layout view.
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 Tip: Reports created with the Report Wizard may have the following two sections in addition to the sections found in reports created by using the Report button.

	Sections of a Report 

	Group Header
	Appears before a group and displays information about the group.

	Group Footer
	Appears after a group and summarizes the group data.


Modify a Report

After you create a report, you can modify it. You can add groups or sorts, add fields, change labels, and perform many other tasks.

You can view a report in Report view, Layout view, Design view, and Print Preview. You can modify a report in Layout view or Design view. In Layout view, you can see your data, and the report you see closely resembles how your report will look when you print it. You can make most, but not all, changes to your report in Layout view. Design view displays the structure of your report. In this view you cannot see the underlying data, but you can perform some tasks in Design view that you cannot perform in Layout view. This tutorial focuses on Layout view.

To change to Layout view:

1. Open your report.

2. Activate the Home tab.

3. Click the View button. A menu appears.

4. Click Layout View. Access changes to Layout view.

Change the Size of a Field or Label
If the data in a field or label seems crowded, if some of the data in the field or label does not appear, or if the data appears as pound signs (####), the field or label is too small.
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To change the size of a field or label:

1. Click the field or label. A border appears around it. 

2. Click a side of the border and drag outward to increase the width. Click a side of the border and drag inward to decrease the width.
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  Tip: Incidentally, if you want to change the height of records, click the top or bottom of a field border and drag upward or downward.

Add a Group or Sort
When you create a report by clicking the Report button, you are not given options that enable you to group or sort. You can use the Group & Sort button on the Format tab to create a group or sort. When you create a report by using the Report Wizard, you can use the Group & Sort button to add or modify a group or sort.

To Group or Sort:

Open the Group, Sort, and Total pane
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1. Open your report in Layout view.

2. Activate the Format tab.

3. Click Group & Sort in the Grouping and Totals group. The Group, Sort, and Total pane appears.

Add a group

[image: image21.png]



4. Click Add A Group and then select the field by which you want to group. Access groups and sorts the field.

Add a sort
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5. Click Add A Sort and then select the field on which you want to sort. Access sorts the field.

Groups and sorts display in the Group, Sort, and Total pane in levels. Access performs the highest-level group or sort first, the second level next, and so on.
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After you have added a group or sort, you can set several options by clicking the More button and then clicking the down-arrow next to each option and making your choices.

	Group, Sort, and Total Pane Options 

	Option
	Description

	Sort order
With A on top
From smallest to largest
From oldest to newest
	Use these options to choose from ascending or descending order.

	Group interval
	Set how you want to group. For example, if you want to group by the first letter of the last name so that all As are together, all Bs are together. etc., you can select By First Character.

	Totals
	Select the field you want to total on and the type of total you want. Your total can be a sum, average, count, etc. You can also choose whether you want to show a grand total, totals as a percentage of a grand total, display totals in the header, or display totals in the footer.

	Title
	Allows you to add or change the field label.

	With or without a header section
	Group headers precede each group. This option allows you to determine whether you want a header section.

	With or without a footer section
	Group footers are printed at the bottom of each group. This option allows you to determine whether you want a footer section.

	Keep group together
	Use these options to determine where a page break will occur when you print:
Do not keep group together on one page. This option allows page breaks within a group.
Keep whole group together on one page. This option prevents page breaks within a group.
Keep header and first record together on one page. This option prevents a header from printing at the bottom of a page with no records.


There are three buttons on the right side of the Group, Sort, and Total pane. If you want to delete a group or sort, click the group or sort you want to delete and then click the Delete button. Groups and sorts execute in the order they are listed in the Group, Sort, and Total pane. If you want to change the order of execution, click the group or sort you want to move up or down and then click the Move Up or Move Down button to move a group or sort up or down a level.

To add a field:
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1. Open your report in Layout view.

2. Activate the Format tab.

3. Click the Add Existing Fields button in the Controls group. The Field List pane appears.

4. Click Show All Tables if the field you want to add does not appear.
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5. Click the field you want to add and drag it onto your report. A thick line appears on the report. Access places the field before the line. If you want the field to appear in the detail area, be sure to drag it to the detail area.

To delete a field:

1. Open your report in Layout view.

2. Click the field you want to delete.

3. Press the Delete key. Access deletes the field.

To move a column:

1. Open your report in Layout view.

2. Click the column label.

3. Drag the column to the new location. Access moves the column to the new location.

To change a title:

1. Open your report in Layout view.

2. Double-click in the Title field.

3. Click and drag to select the current title.

4. Type a new title.

5. Click anywhere outside the Title field. Access changes the title.

To change a field label:

1. Open your report in Layout view.

2. Double-click the field label.

3. Click and drag to select the label name.

4. Type the new label name.

5. Click anywhere outside the label. Access changes the field label.

To change the paper size:

1. Open your report in Layout view.

2. Activate the Page Setup tab.

3. Click the Size button in the Page Layout group. A menu appears.

4. Click the size of the paper you are going to print on.

To change paper orientation:

1. Open your report in Layout view.

2. Activate the Page Setup tab.

3. Click Portrait or Landscape to choose the orientation you want to use. Access changes the page orientation.

To change margins:

1. Open your report in Layout view.

2. Activate the Page Setup tab.

3. Click the Margins button in the Page Layout group. A menu appears.

4. Click the margin size you want. Access changes the page margin.

To add page numbers:

1. Open your report in Layout view.

2. Activate the Format tab.

3. Click the Insert Page Number button  in the Controls group. The Page Numbers dialog box appears.

4. Click a radio button to choose a format.

5. Click a radio button to choose a position.

6. Click the down-arrow in the Alignment field and then choose an alignment.

7. Deselect Show Number On First Page if you do not want the page number to appear on the first page.

8. Click OK. Access places the page number in your report.

To add current date or time:

1. Open your report in Layout view.

2. Activate the Format tab.

3.  Click the Date and Time button [image: image27.png]


 in the Controls group. The Date and Time dialog box appears.
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4. Deselect the Include Date box if you do not wish to include the date.

5. Click to select a format if you are including the date.

6. Deselect the Include Time box if you do not wish to include the time.

7. Click to select a format if you are including the time.

8. Click OK. Access places the date and/or time in your report.

Apply an AutoFormat
You can use the AutoFormat option on the Format tab to apply formats such as background colors, fonts, and font sizes quickly.

To apply an AutoFormat:

1. Activate the Format tab.

2. Click AutoFormat. The AutoFormat menu appears.

3. Click the format you want to apply.

Change Fonts and Formats
You can use options on the Format tab to manually apply formats to your report. However, before you can apply a format to a field or field label, you must select the field or field label by clicking it. To select multiple items, hold down the Shift key and then click each item you want to select. A box surrounds selected items.

	Change Fonts and Formats 

	Button
	Shortcut Key
	Function

	Layout View—Format Tab, Font Group
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	Apply a font to the current selection.
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	Set the size of the font for the current selection.
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	Ctrl-b
	Bold the current selection.
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	Ctrl-i
	Italicize the current selection.
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	Ctrl-u
	Underline the current selection.
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	Ctrl-l
	Left-align the selection.
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	Ctrl-r
	Right-align the selection.
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	Ctrl-e
	Center the selection.
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	Change the font color.
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	Change the background color.
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	Change the alternating color. For example, you can have every other row in the detail area appear in alternating colors.

	Layout View—Format Tab, Formatting Group
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	Apply a Number format.
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	Use a currency symbol.
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	Change to percent.
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	Use thousand separators.
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	Increase decimal places.
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	Decrease decimal places.

	Layout View—Format Tab, Gridlines Group
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	Add gridlines.
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	Change the weight of gridlines.
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	Change the style of gridlines.
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	Change the color of gridlines.

	Layout View—Format Tab, Controls Group
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	Add a logo.
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	Add a title.
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	Set line thickness.
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	Set line style.
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	Set line color.
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  Tip: After you modify your report, you must save it if you want to keep the changes. To save, click the Save button on the Quick Access toolbar or right-click the report’s tab and then click Save.

Create Mailing Labels

In Access, the easiest way to create a mailing label is to use the Label Wizard. The Label Wizard extracts name and address data from your database and formats it so you can print it on commercially available labels.

Each time you view or print labels, the data are extracted from the database, so as you update your database, Access updates your labels.

To create labels:

Open the Labels Wizard
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1. Click the table or query you want to use to create a label.

2. Activate the Create tab.

3. Click Labels in the Reports group. The Labels Wizard appears.

Choose a product number

Most commercially available labels have a product number. You should be able to find the number on the box. You use the product number to tell Access the dimensions of your labels and the number of columns and rows that are on a page.
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1. Click to select the Product Number in the Product Number field.

2. Click Next. The Label Wizard moves to the next page.

Choose a font, font size, font weight, and color

A font is a set of characters (text) represented in a single typeface. Each character within a font is created by using the same basic style. The Label Wizard has options that allow you to select a font, font size, weight, and color. You can also choose to italicize or underline the text in your labels.
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1. Click the down-arrow next to the Font Name field and then select the font. A preview appears in the Sample box.

2. Click the down-arrow next to the Font Size field and then select the font size. A preview appears in the Sample box.

3. Click the down-arrow next to the Font Weight field and then select the font weight. A preview appears in the Sample box.

4. Click the button next to the Text Color field and then select a color you want your text to have. A preview appears in the Sample box.

5. Click the Italic box if you want to italicize. A preview appears in the Sample box.

6. Click the Underline box if you want to underline. A preview appears in the Sample box.

7. Click Next. The Label Wizard moves to the next page.

Create a layout

You create the layout of your labels by selecting fields and placing them in the Prototype Label box. You type any text or spaces that you want to appear on your label.
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1. Click a field name and then click the right-arrow to place the field on the prototype label.

2. Press the spacebar to leave spaces.

3. Press the Enter key to move to a new line.

4. Type any text you want to appear on the label.

5. Click Next. The Label Wizard moves to the next page.

Sort

When creating labels, you can sort on any field and you can have multiple levels of sort. For example, you can sort by last name and then by first name.
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1. Click to choose the fields you want to sort by. Click the single right-arrow to select a single field, click the double right-arrow to select all fields, click the single left-arrow to deselect a single field, click the double left-arrow to deselect all fields.

2. Click Next. The Label Wizard moves to the next page.

Title the report
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1. Type a title for your report. The title will appear in the Navigation pane.

2. Click Finish. Access displays the labels in Print Preview.
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  Tip: When you complete your labels you may get the following message.

When printing mailing labels, you can usually ignore this message. Click the Show Help button to read the following:

	This message may be the result of using a report created with the Label Wizard. This error message is commonly encountered when printing to label pages that have three or more labels per row. Usually this message can be ignored.
If you do need to change the layout, try one or both of the following:

· Reduce the width of the controls on the report.

· Reduce the width of the report to make sure the report is not wider than the printable area of the page.

Note that page size is dependent on the printer and the physical size of the paper you are printing to. In some cases it is necessary to rotate the page orientation from portrait to landscape to accommodate the selected print width.
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Tip: When you view labels in Report view, they may appear in a single column. To see how your labels will appear when printed, use Print Preview.

Print a Report

Often, the people who use Access data only see a printed report. In Print Preview, you can see exactly how your report will look when printed, you can make changes to it, and you can print it. To print, click the Print button in the Print group. The Print dialog box opens and you can select your print options.

To change to Print Preview:

1. Open your report.

2. Activate the Home tab.

3. Click the down-arrow under the View button. A menu appears.

4. Click Print Preview. Access changes to Print Preview.

Several options are available to you in Print Preview.

	Print Preview Options 

	Print
	Displays the Print dialog box. You can select such options as the printer, print range, and number of copies. Use this option to print your report.

	Size
	Click the Size button to set the size of the paper you are going to print on.

	Portrait
	Click the Portrait button to print with the shortest side of the paper as the top.

	Landscape
	Click the Landscape button to print with the longest side of the paper as the top.

	Margins
	Click the Margins button to select a margin size of Normal, Wide, or Narrow. Margins define the amount of white space that surrounds your report.

	Print Data Only
	Prints the report data without other elements such as titles, and labels. 

	Zoom
	Changes the cursor to a magnifying glass. When the magnifying glass displays a minus sign (–), you can zoom out. When the magnifying glass displays a plus sign (+), you can zoom in.
Click the down-arrow under the Zoom button to display a menu and choose a zoom level.

	One Page
	Displays one page of the report in the Access window.

	Two Page
	Displays two pages of the report in the Access window.

	More Pages
	Displays a menu from which you can choose the number of page you want to display.
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Tip: To view a report online, use Report view. Open your report. Activate the Home tab. Click the down-arrow under the View button. Click Report view. Your report displays in Report view.

